Search found 393 matches

by kamermans
Tue Jul 19, 2011 10:17 pm
Forum: PHP API
Topic: There is no device with id [generic] in wurfl
Replies: 14
Views: 24214

Re: There is no device with id [generic] in wurfl

We've just released a new version of the PHP API that addresses this problem directly: http://bit.ly/p9h4Dc
by kamermans
Tue Jul 19, 2011 2:39 pm
Forum: PHP API
Topic: There is no device with id [generic] in wurfl
Replies: 14
Views: 24214

Re: There is no device with id [generic] in wurfl

The problem is Solaris-specific in that PHP tries to obtain an exclusive file lock on the WURFL.XML to prevent multiple instances of the updater from updating the WURFL at the same time. In Solaris, a read-only exclusive file lock is not possible (http://www.php.net/manual/en/function.flock.php#9340...
by kamermans
Tue Jul 19, 2011 1:57 pm
Forum: PHP API
Topic: There is no device with id [generic] in wurfl
Replies: 14
Views: 24214

Re: There is no device with id [generic] in wurfl

Can you put this in your header-config.inc under the two define() statements? if(!file_exists(RESOURCES_DIR.'persistence') && !mkdir(RESOURCES_DIR.'persistence', 0777, true)){ echo "storage/persistence directory does not exist and I can't create it: ".RESOURCES_DIR.'persistence'."<br/>\n"; } echo "<...
by kamermans
Tue Jul 19, 2011 1:44 pm
Forum: PHP API
Topic: There is no device with id [generic] in wurfl
Replies: 14
Views: 24214

Re: There is no device with id [generic] in wurfl

Ok, that's a more typical error message, like you said. I guess we can continue down the original path, with your header-config.inc. Something that would be helpful for troubleshooting is to edit inc/header-config.inc and make sure the top of the file looks like this: <?php ini_set("display_errors",...
by kamermans
Tue Jul 19, 2011 1:32 pm
Forum: PHP API
Topic: There is no device with id [generic] in wurfl
Replies: 14
Views: 24214

Re: There is no device with id [generic] in wurfl

Ok, can you try change the wurfl-config.xml that you're using with the demo page to "/var/mobile/wurfl/wurfl-config.xml" to see if that solves the problem? Perhaps there is a specific requirement in your organization that is different than most.
by kamermans
Tue Jul 19, 2011 1:12 pm
Forum: PHP API
Topic: There is no device with id [generic] in wurfl
Replies: 14
Views: 24214

Re: There is no device with id [generic] in wurfl

In that case, this is a little strange because the persistence is not being built. There should be a large number of files here: http://mtest.drake.edu/carl/examples/resources/storage/persistence/ If you have PHP Safe Mode on then your webserver's process will need to be the owner of the storage/per...
by kamermans
Tue Jul 19, 2011 12:30 pm
Forum: PHP API
Topic: There is no device with id [generic] in wurfl
Replies: 14
Views: 24214

Re: There is no device with id [generic] in wurfl

This is most likely because your resources/storage directory is not currently writable by the webserver.

Please try making the directory writable by using a command like this:

chmod -R 777 /var/apache2/htdocs/mtest/carl/examples/resources/storage
by kamermans
Sat Jul 16, 2011 7:29 am
Forum: Device Detection Issues
Topic: Issues with IE 9
Replies: 6
Views: 5883

Re: Issues with IE 9

Since the WURFL.XML web patch are updated, it must be the API that is causing the issue. You will need to update it with the current PHP API.
by kamermans
Wed Jul 13, 2011 4:02 pm
Forum: Device Detection Issues
Topic: HTML error
Replies: 1
Views: 3002

Re: HTML error

I can see from your page's source code that your server is not parsing the page as PHP: <?php require_once("Tera-Wurfl/TeraWurfl.php"); $wurflObj = new TeraWurfl(); $wurflObj->getDeviceCapabilitiesFromAgent(); $isWireless = $wurflObj->getDeviceCapability("is_wireless_device"); if($isWireless) header...
by kamermans
Wed Jul 13, 2011 3:57 pm
Forum: Device Detection Issues
Topic: Issues with IE 9
Replies: 6
Views: 5883

Re: Issues with IE 9

At a minimum you will need to update your WURFL.XML and web browsers patch. There are probably a lot of other devices and/or browsers that are being incorrectly identified.

Which API or at least what language are you using?
by kamermans
Sat Jul 09, 2011 9:14 am
Forum: Device Detection Issues
Topic: Caching & returning different device ID
Replies: 3
Views: 4295

Re: Caching & returning different device ID

Ok, well I'm glad it's resolved as it sounds like a very tricky problem to track down!
by kamermans
Thu Jul 07, 2011 9:01 am
Forum: .NET API
Topic: strongly typed capabilities?
Replies: 2
Views: 5700

Re: strongly typed capabilities?

It should be noted that in the Database API (aka Tera-WURFL) and WURFL Cloud, numeric and boolean values are strongly typed, so is_wireless_device === true.
by kamermans
Thu Jul 07, 2011 8:38 am
Forum: Device Detection Issues
Topic: Caching & returning different device ID
Replies: 3
Views: 4295

Re: Caching & returning different device ID

Hi David, This is very strange indeed! I'm not sure how this is happening, but I'll certainly look into it. A preliminary check on a few of my test boxes, including Tera-WURFL Explorer shows this device being detected as dell_streak_7_ver1 . Can you verify that the script you are using to see the ID...