Search found 393 matches

by kamermans
Tue Oct 15, 2013 8:58 am
Forum: ScientiaMobile WURFL Cloud Service
Topic: New Capabilities from API 1.5 ?
Replies: 5
Views: 5022

Re: New Capabilities from API 1.5 ?

We've made some changes to the way these capabilities are cached, and pushed them live, so everything should be working properly now.
by kamermans
Tue Oct 15, 2013 7:45 am
Forum: ScientiaMobile WURFL Cloud Service
Topic: New Capabilities from API 1.5 ?
Replies: 5
Views: 5022

Re: New Capabilities from API 1.5 ?

Thanks for the info - there may be a cache-related issue that is causing this on our side. We are looking into it and will let you know when we determine the cause.
by kamermans
Mon Oct 14, 2013 6:49 pm
Forum: ScientiaMobile WURFL Cloud Service
Topic: New Capabilities from API 1.5 ?
Replies: 5
Views: 5022

Re: New Capabilities from API 1.5 ?

Our blog post beat our implementation team by a couple days - sorry about that!

The WURFL Cloud service is being updated now and you will be able to select the new capabilities within the hour.
by kamermans
Mon Oct 14, 2013 6:44 pm
Forum: Database API
Topic: Missing VirtualCapability folder in DB API 1.5.0.1
Replies: 1
Views: 8573

Re: Missing VirtualCapability folder in DB API 1.5.0.1

Sorry about the oversight, we will get the updated version on the site ASAP. In the meantime, I'm attaching the updated distribution.
by kamermans
Mon Oct 14, 2013 6:35 pm
Forum: Device Detection Issues
Topic: Cannot detect details from some browsers
Replies: 5
Views: 7597

Re: Cannot detect details from some browsers

Hi, The API does not currently detect the browser separately from the device, so sometimes you will get the results for the default browser that ships with the device. Note that you are using the WURFL.XML that came with version 1.4 of the API. We recently released v1.5 of the API, which will signif...
by kamermans
Mon Oct 14, 2013 6:32 pm
Forum: Device Detection Issues
Topic: UCWeb browser query
Replies: 11
Views: 8161

Re: UCWeb browser query

Hi Chris,

The WURFL Cloud service has been updated, and it is returning the expected results.
by kamermans
Mon Oct 14, 2013 6:24 pm
Forum: Database API
Topic: Worth reinstalling all files?
Replies: 1
Views: 8610

Re: Worth reinstalling all files?

Hi Jayson, We just released version 1.5 of our API, and it is highly recommended that you update to this version since it contains many improvements. That having been said, although all updates are important, the major (ex: 1.5 to 2.0) and minor (ex 1.4 to 1.5) updates should be a priority, as they ...
by kamermans
Fri Oct 11, 2013 9:00 am
Forum: ScientiaMobile WURFL Cloud Service
Topic: Advice please - on Cloud API performance techniques
Replies: 2
Views: 3272

Re: Advice please - on Cloud API performance techniques

Hi Chris, Your assumptions are correct. The cloud can be faster than the OnSite API due to it's lightweight caching, but most requests will be longer. If your servers are in the US or Europe on a decent backbone, you should be averaging <100ms round trip for requests, however, some of your lookups w...
by kamermans
Wed Oct 09, 2013 11:07 am
Forum: .NET API
Topic: The remote server returned an error: (401) Unauthorized
Replies: 6
Views: 9656

Re: The remote server returned an error: (401) Unauthorized

I see no attempts to authenticate against our system from your API key. Can you tell me what IP you are accessing our system from so I can track down your requests? You can PM it to me if you want, for the sake of security. Also, I have tested your API key manually and it seems to be working fine.
by kamermans
Wed Oct 09, 2013 10:20 am
Forum: Miscellaneous
Topic: Infinite loop in php code
Replies: 7
Views: 11949

Re: Infinite loop in php code

I have found the problem. Issue #1: the WURFL version you are using is much older than the API, and the API is hardcoded with some device IDs that must be present. For this reason, you must use a WURFL that is as new as, or newer than, the API. We will try to make this requirement more obvious, so I...
by kamermans
Wed Oct 09, 2013 10:02 am
Forum: .NET API
Topic: The remote server returned an error: (401) Unauthorized
Replies: 6
Views: 9656

Re: The remote server returned an error: (401) Unauthorized

Help is on the way! :)

Sorry for the delay, I am going to check our load balanacers to see where your traffic is going and what the issue is. Can you tell me what country you are testing the service from (your traffic is geo-routed to a nearby cluster of servers)?
by kamermans
Wed Oct 09, 2013 9:51 am
Forum: Miscellaneous
Topic: Infinite loop in php code
Replies: 7
Views: 11949

Re: Infinite loop in php code

Sure, no problem. Please let me know if you are able to reproduce this issue. I will also test it on my side with MySQL as a persistence layer.

Do you have any caching enabled?
by kamermans
Wed Oct 09, 2013 9:43 am
Forum: ScientiaMobile Licensing
Topic: Standard cloud account and subdomains
Replies: 1
Views: 8132

Re: Standard cloud account and subdomains

The intent of the constraint is to limit you to two websites with different content. If, for example, you have www.example.com and ftp.example.com and staging.example.com and qa.example.com and m.example.com, these are one domain. It you have customer1.example.com, customer2.example.com, customer3.e...
by kamermans
Wed Oct 09, 2013 9:36 am
Forum: Miscellaneous
Topic: Infinite loop in php code
Replies: 7
Views: 11949

Re: Infinite loop in php code

Hi Cliff, While we haven't released a new public WURFL snapshot, the v1.5 API does ship with a brand-new WURFL file, so you're welcome to use that. With regards to the infinite loop, this is due to a missing 'generic' device. I can patch the code to avoid the loop, but it will still throw an excepti...
by kamermans
Tue Oct 08, 2013 9:58 am
Forum: .NET API
Topic: The remote server returned an error: (401) Unauthorized
Replies: 6
Views: 9656

Re: The remote server returned an error: (401) Unauthorized

It can take up to a few minutes for changes to a WURFL Cloud account to propagate to all servers, is it possible that this could be the issue? Also, make sure the capabilities you selected were actually saved, because this can also be caused by having no capabilities selected.
by kamermans
Mon Oct 07, 2013 6:32 pm
Forum: General API Questions
Topic: Demo not working: no capability name[brand_name]
Replies: 5
Views: 11905

Re: Demo not working: no capability name[brand_name]

Glad to hear you're up and running! Yes, the performance will be increased if capability filtering is used, but it's typically only noticeable on high-traffic sites. It also decreases the size of the persistence folder and the cache (whether on disk or otherwise).
by kamermans
Mon Oct 07, 2013 6:29 pm
Forum: ScientiaMobile WURFL Cloud Service
Topic: Cloud Service SLA
Replies: 1
Views: 2698

Re: Cloud Service SLA

Hi, Our SLA is covered in the terms and conditions page: http://www.scientiamobile.com/site/page/view/cloud_terms I can check the specific language that you're interested in, but in PHP the connection is only allowed to take 1 second before it fails and throws and exception, so you can wrap the call...
by kamermans
Mon Oct 07, 2013 9:40 am
Forum: General API Questions
Topic: Demo not working: no capability name[brand_name]
Replies: 5
Views: 11905

Re: Demo not working: no capability name[brand_name]

Sorry for the trouble. This error is caused by the default configuration - we will fix it an re-release it ASAP, but in the meantime, here's what you can do. Open the file examples/demo/inc/wurfl_config_standard.php and find this section: // Optionally specify which capabilities should be loaded $wu...
by kamermans
Mon Oct 07, 2013 9:40 am
Forum: PHP API
Topic: no capability named [resolution_height] is present in wurfl
Replies: 2
Views: 7648

Re: no capability named [resolution_height] is present in wu

Sorry for the trouble. This error is caused by the default configuration - we will fix it an re-release it ASAP, but in the meantime, here's what you can do. Open the file examples/demo/inc/wurfl_config_standard.php and find this section: // Optionally specify which capabilities should be loaded $wu...
by kamermans
Fri Sep 13, 2013 11:18 am
Forum: PHP API
Topic: Show correct app link to mobile users
Replies: 4
Views: 9106

Re: Show correct app link to mobile users

You can include more "else if" statements: if ($os == 'Android') { // Show Android app link } else if ($os == 'iOS') { // Show iOS app link } else if ($os == "RIM OS") { // Show BlackBerry app link } else if ($os == "Windows Mobile OS" || $os == "Windows Phone OS") { // Show Windows app link } else ...