Search found 393 matches

by kamermans
Thu Sep 12, 2013 11:37 am
Forum: PHP API
Topic: Show correct app link to mobile users
Replies: 4
Views: 9109

Re: Show correct app link to mobile users

You can certainly do this with WURFL. We can't really write up a full example, but this is essentially the what you would do in your page: <?php // Create a WURFL Cloud Config $config = new WurflCloud_Client_Config(); // Set your API Key here $config->api_key = 'xxxxxx:xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx...
by kamermans
Wed Sep 11, 2013 3:49 pm
Forum: ScientiaMobile WURFL Cloud Service
Topic: WURFL demo servelt run time error in java
Replies: 7
Views: 6847

Re: WURFL demo servelt run time error in java

Have you confirmed that there is no web proxy in your environment? Most modern browsers will detect the presence of a proxy and use it for HTTP traffic, but java/weblogic will not.
by kamermans
Tue Sep 10, 2013 8:09 pm
Forum: ScientiaMobile WURFL Cloud Service
Topic: WURFL demo servelt run time error in java
Replies: 7
Views: 6847

Re: WURFL demo servelt run time error in java

Certainly there is a network issue if you are unable to ping api.wurflcloud.com. The client makes requests to that host via HTTP (port 80), although if you visit it with your browser, it will respond with something like "Not found". You must have one of these two problems: 1. DNS is not working. You...
by kamermans
Tue Sep 10, 2013 8:56 am
Forum: ScientiaMobile WURFL Cloud Service
Topic: Firewall Problem
Replies: 10
Views: 11637

Re: Firewall Problem

We will certainly consider adding support to the .NET client, I just know that it will be very easy to update the PHP client since I am a PHP developer :)
by kamermans
Mon Sep 09, 2013 4:17 pm
Forum: ScientiaMobile WURFL Cloud Service
Topic: Firewall Problem
Replies: 10
Views: 11637

Re: Firewall Problem

Unfortunately, the client does not support a proxy at this time, although if you are using one of the scripting languages, like PHP, you can easily modify the adapter to support an HTTP proxy like this: http://blog.proxybonanza.com/programming/php-curl-with-proxy/ Please let me know which language y...
by kamermans
Thu Sep 05, 2013 12:57 am
Forum: ScientiaMobile WURFL Cloud Service
Topic: Please Help
Replies: 3
Views: 3933

Re: Please Help

Can you please post the code that shows how you are using the client? Everything is working fine when I test that specific user agent, but I wonder if something in your environment is doing something strange, like URL encoding the user agent before it is sent to us?
by kamermans
Tue Aug 27, 2013 12:09 pm
Forum: Feature Requests
Topic: Can not detect mobile use opera browser
Replies: 5
Views: 14889

Re: Can not detect mobile use opera browser

Please note that Opera has now changed the header from X-OperaMini-Phone-UA to Device-Stock-UA. Older versions of the browser will still use the old header and all newer versions will use the new header.
by kamermans
Thu Aug 15, 2013 10:36 am
Forum: .NET API
Topic: KeyNotFoundException in EnsureUserAgent
Replies: 6
Views: 9239

Re: KeyNotFoundException in EnsureUserAgent

Is it possible that your list of capabilities has been changed on our side (the WURFL Cloud control panel)? Are you able to reproduce the issue from a client, or could it be that there is some strange HTTP traffic coming in, perhaps without a user agent header at all?
by kamermans
Tue Aug 13, 2013 2:17 pm
Forum: Varnish Cache, Apache, NGINX Modules and WURFL C++ API
Topic: Documentation
Replies: 3
Views: 9887

Re: Documentation

It sounds like you got a WURFL file directly from us, and that file contained proposed capabilities which are not yet available to the general public. These capabilities are not yet documented and are not included in public WURFL releases or in the WURFL files that you retrieve from your customer va...
by kamermans
Tue Aug 13, 2013 1:50 pm
Forum: Device Detection Issues
Topic: Incorrect browser detection?
Replies: 1
Views: 3064

Re: Incorrect browser detection?

Sorry for the trouble. This is a known issue for some user agent strings since the goal of the API is to match the request to the device profile, and in some cases, third party browsers are not properly identified. We are addressing this directly in the v2.0 release of the API, which will be sometim...
by kamermans
Tue Jul 23, 2013 3:16 pm
Forum: PHP API
Topic: Installation OK but testing gives a error
Replies: 11
Views: 14258

Re: Installation OK but testing gives a error

Ok, thanks for the info, and I'm glad you've got it working!
by kamermans
Tue Jul 23, 2013 7:34 am
Forum: PHP API
Topic: Installation OK but testing gives a error
Replies: 11
Views: 14258

Re: Installation OK but testing gives a error

Sorry for the confusion, this file is included in DB API distribution by us as part of the GUI-based patching system. It is no longer relevant and will be removed in future versions, but it will not have any effect on your installation. There is something else going on here, something systemic. Perh...
by kamermans
Mon Jul 22, 2013 9:29 pm
Forum: PHP API
Topic: Installation OK but testing gives a error
Replies: 11
Views: 14258

Re: Installation OK but testing gives a error

The output looks correct, but the database stats from your previous post show that the database is empty, which is not good:

Code: Select all

Database Table	Statistics
MERGE
TeraWurflMerge	Rows: 0
Actual Devices: 0 
Table Size: 0 B
Are you still having the same problem?
by kamermans
Mon Jul 22, 2013 9:08 am
Forum: General API Questions
Topic: Automatically updating commercial WURFL file
Replies: 9
Views: 40167

Re: Automatically updating commercial WURFL file

Hi Alex,

Your sales rep will need to create a license for you in our system first. I will ping them to see what is causing the delay.
by kamermans
Sun Jul 21, 2013 10:57 pm
Forum: PHP API
Topic: Installation OK but testing gives a error
Replies: 11
Views: 14258

Re: Installation OK but testing gives a error

It looks like something failed while loading the WURFL database. Can you try to load the WURFL data again and paste the resulting page here?
by kamermans
Wed Jul 17, 2013 10:36 pm
Forum: Device Detection Issues
Topic: not getting all capabilities (1.4.4.0)
Replies: 4
Views: 4448

Re: not getting all capabilities (1.4.4.0)

Indeed, iPhone OS was changed to iOS a few months ago in order to align with the current Apple naming convention. We sent out a notification stressing this change, but it's possible that you did not receive it. I can give you the link to sign up for these alerts, although everyone that has a Scienti...
by kamermans
Thu Jul 11, 2013 9:46 pm
Forum: ScientiaMobile WURFL Cloud Service
Topic: PHP Client Wurfl Cloud not returning device_os
Replies: 1
Views: 3920

Re: PHP Client Wurfl Cloud not returning device_os

Hi, The WURFL Cloud Service is in high-performance, which does not attempt to accurately detect desktop user agents. In the case of the user agent you posted, the best match is Firefox in high-accuracy mode (if you were using WURFL OnSite this is configurable), but will be detected as a generic web ...
by kamermans
Mon Jul 08, 2013 10:15 am
Forum: .NET API
Topic: Updated my capabilities
Replies: 7
Views: 10966

Re: Updated my capabilities

Hi Minesh,

Sorry about the trouble, I am going to look into this personally and see where the delay could be. Can you also tell me which country your server is in, so I can look at your traffic in that region?
by kamermans
Fri Jul 05, 2013 11:54 am
Forum: .NET API
Topic: Updated my capabilities
Replies: 7
Views: 10966

Re: Updated my capabilities

The capabilities are sync'd to all WURFL Cloud servers within a couple minutes after you save them in the WURFL Cloud Control panel. Currently it looks like you only have "viewport_width" selected. Are you still having trouble?
by kamermans
Wed Jul 03, 2013 9:26 pm
Forum: Device Detection Issues
Topic: Tablet Detection
Replies: 26
Views: 28315

Re: Tablet Detection

There is up to a 5-minute delay in changing your capabilities in the WURFL Cloud control panel, and seeing the new capabilities in the responses from the cloud service. You should also verify that your code is not specifically requesting is_wireless_device and not is_tablet, as that would be another...