Version 1.8.0.0 via NuGet

michael.vannevel
Posts: 3
Joined: Fri Jul 29, 2016 2:00 pm

Version 1.8.0.0 via NuGet

Postby michael.vannevel » Fri Jul 29, 2016 2:06 pm

I recently updated our company's wurfl to version 1.8.0.0. Each time i try to debug our project, on App Initialization in the global.asax, i get a memory error like below:

FatalExecutionEngineError was detected
The runtime has encountered a fatal error. The address of the error was at 0x0bd39423, on thread 0x379c. The error code is 0x80131623. This error may be a bug in the CLR or in the unsafe or non-verifiable portions of user code. Common sources of this bug include user marshaling errors for COM-interop or PInvoke, which may corrupt the stack.

Has anyone else seen this error? We have never had any issue up until version 1.8.0.0.

aaronp
Posts: 223
Joined: Wed Dec 09, 2015 12:39 pm

Re: Version 1.8.0.0 via NuGet

Postby aaronp » Fri Jul 29, 2016 2:19 pm

Hi Michael,

I noticed that your last WURFL snapshot update occurred on the 29th of June. Are you able to update your `wurfl.zip` to the latest release and try running WURFL again?

Look forward to hearing back.

Thanks,

Aaron

michael.vannevel
Posts: 3
Joined: Fri Jul 29, 2016 2:00 pm

Re: Version 1.8.0.0 via NuGet

Postby michael.vannevel » Mon Aug 01, 2016 9:52 am

The zip file we have on our server is from 7/30/2016 and that is what i used to test. We have a process that pulls it every day i believe, in case there are changes.

aaronp
Posts: 223
Joined: Wed Dec 09, 2015 12:39 pm

Re: Version 1.8.0.0 via NuGet

Postby aaronp » Mon Aug 01, 2016 10:58 am

Hi Michael,

It appears that the issue is occurring due to an error during the obfuscation phase of the .dll

I have uploaded an updated version of the API (v1.8.0.1) addressing this issue to your File Manager (first login to your ScientiaMobile account, then 'My Account' -> 'File Management' -> 'Products' -> 'OnSite').

Please give it a try a let us know how it goes.

Thanks,

Aaron

michael.vannevel
Posts: 3
Joined: Fri Jul 29, 2016 2:00 pm

Re: Version 1.8.0.0 via NuGet

Postby michael.vannevel » Mon Aug 01, 2016 12:10 pm

This version of the dll works. Will you be posting this new version to NuGet? Also are the dlls you sent production ready?

aaronp
Posts: 223
Joined: Wed Dec 09, 2015 12:39 pm

Re: Version 1.8.0.0 via NuGet

Postby aaronp » Mon Aug 01, 2016 12:18 pm

Michael,

API v1.8.0.1 has been published to NuGet (https://www.nuget.org/packages/WURFL_Official_API) and the .dll files are production ready. Let me know if you have any other questions or concerns.

Thanks,

Aaron


Who is online

Users browsing this forum: No registered users and 1 guest