Please Help

Questions about the WURFL Cloud service.
lcapece
Posts: 5
Joined: Fri Mar 15, 2013 5:44 am

Please Help

Postby lcapece » Wed Sep 04, 2013 4:58 pm

I am a cloud service subscriber and have a massive problem. About 75% of all agent lookups are returning the SAME incorrect capabilities. For example:

Mozilla/5.0 (Linux; U; Android 4.0.3; en-us; HTCEVODesign4G Build/IML74K) AppleWebKit/534.30 (KHTML| like Gecko) Version/4.0 Mobile Safari/534.30 (Mobile; afma-sdk-a-v6.4.1)

Is returning "Generic Android 2.0" date "2009_October". I hope someone is manning the boards can help! Thanks.

lcapece
Posts: 5
Joined: Fri Mar 15, 2013 5:44 am

Re: Please Help

Postby lcapece » Wed Sep 04, 2013 5:00 pm

Forgot to mention, this is from .net cloud API

kamermans
Posts: 393
Joined: Mon Jun 06, 2011 9:50 am

Re: Please Help

Postby kamermans » Thu Sep 05, 2013 12:57 am

Can you please post the code that shows how you are using the client? Everything is working fine when I test that specific user agent, but I wonder if something in your environment is doing something strange, like URL encoding the user agent before it is sent to us?
Thanks,

Steve Kamerman
ScientiaMobile

Make sure you check out our WURFL Cloud, WURFL InSight and WURFL InFuze products!

sm_support2
Posts: 294
Joined: Mon Jun 20, 2011 5:04 pm

Re: Please Help

Postby sm_support2 » Thu Sep 05, 2013 8:16 am

lcapece wrote: Mozilla/5.0 (Linux; U; Android 4.0.3; en-us; HTCEVODesign4G Build/IML74K) AppleWebKit/534.30 (KHTML| like Gecko) Version/4.0 Mobile Safari/534.30 (Mobile; afma-sdk-a-v6.4.1)
We recognize that user-agent correctly, so the problem is most probably elsewhere. As Steve wrote, can you please post the code you use to retrieve the user-agent and make sure that there is nothing (encoding? stray toLowerCase()?) that interferes with the detection?

thanks


Who is online

Users browsing this forum: No registered users and 1 guest