QQBrowser is not detected

I have this HTTP request, I expected this, but WURFL is returning that. Please provide enough data to reproduce the problem.
VitalyOrbitsoft
Posts: 1
Joined: Wed Feb 07, 2018 9:48 am

QQBrowser is not detected

Postby VitalyOrbitsoft » Wed Feb 07, 2018 9:58 am

Here is some examples of browser user-agents and the result of detecting:

UA: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/53.0.2785.104 Safari/537.36 Core/1.53.2669.400 QQBrowser/9.6.10990.400

Code: Select all

// $_SERVER['WURFL_ADVERTISED_BROWSER'] = 'Chrome';
UA: Mozilla/5.0 (Windows NT 6.2; WOW64; Trident/7.0; Touch; .NET4.0E; .NET4.0C; .NET CLR 3.5.30729; .NET CLR 2.0.50727; .NET CLR 3.0.30729; InfoPath.3; Tablet PC 2.0; QQBrowser/7.6.21433.400; rv:11.0) like Gecko

Code: Select all

// $_SERVER['WURFL_ADVERTISED_BROWSER'] = 'IE';
UA: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; .NET4.0C; .NET4.0E; QQBrowser/6.12)

Code: Select all

// $_SERVER['WURFL_ADVERTISED_BROWSER'] = 'IE';
UA: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; QQBrowser/6.12)

Code: Select all

// $_SERVER['WURFL_ADVERTISED_BROWSER'] = 'IE';
WURFL DB last updated: 2018-02-04 00:30:21 -0500

aaronp
Posts: 223
Joined: Wed Dec 09, 2015 12:39 pm

Re: QQBrowser is not detected

Postby aaronp » Wed Feb 07, 2018 11:34 am

Hi Vitaly,

Thank you for providing the information. My data team is taking a look at the provided user agents for consideration to our database. While I cannot make any guarantees at the moment, If the user agents are validated, they will be added and picked up in a future API release.

Let me know if you have any other questions or concerns.

Thanks,

Aaron


Who is online

Users browsing this forum: No registered users and 2 guests