Only detecting iOS phone model when using FB app?

I have this HTTP request, I expected this, but WURFL is returning that. Please provide enough data to reproduce the problem.
mcolella
Posts: 1
Joined: Mon Jun 04, 2018 2:47 pm

Only detecting iOS phone model when using FB app?

Postby mcolella » Mon Jun 04, 2018 2:52 pm

I'm having a strange issue. I've been collecting data for years now and am just noticing this now. It appears though i'm only collecting what iOS phone model the user is using IF they are using the FB app. If they use safari, it is not collected. Please view the following screenshot:

https://www.screencast.com/t/SNlQkMQg5q9C

Is this standard functionality or is something wrong in my config? Could anybody shed some light on this?

aaronp
Posts: 228
Joined: Wed Dec 09, 2015 12:39 pm

Re: Only detecting iOS phone model when using FB app?

Postby aaronp » Mon Jun 04, 2018 3:16 pm

Hi,

Thanks for reaching out. The reason why iOS models are detected through Facebook is because the user agent from the Facebook app, on an Apple device, will return hardware information; whereas it doesn't give any hardware information from any browser.

Identifying the underlying hardware for iOS devices by analyzing the HTTP headers alone is an uphill task. In certain cases, we are able to perform hardware level device identification for iOS devices by looking at the User-Agent string and I will talk about that below

Certain apps like Facebook, Instagram and Snapchat append a hardware identifier for iOS devices in the User-Agent string and we are able to leverage that to perform device level detection.

If you have any further questions or concerns, please feel free to reach out to us directly at support@scientiamobile.com

Thanks,

Aaron


Who is online

Users browsing this forum: No registered users and 4 guests