IE user-agent with "tablet" attribute detected as mobile

I have this HTTP request, I expected this, but WURFL is returning that. Please provide enough data to reproduce the problem.
wyanar
Posts: 1
Joined: Mon Jul 18, 2011 5:05 am

IE user-agent with "tablet" attribute detected as mobile

Postby wyanar » Mon Jul 18, 2011 5:07 am

I have a user on desktop IE 9 with the following user-agent being detected as mobile (is_wireless_device=true).
I am using the .NET API.
It seems that the API sees the attribute "Tablet" and disregard it as a IE web browser.
Should this be the correct behavior?

Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; Trident/5.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; InfoPath.2; Tablet
PC 2.0; OfficeLiveConnector.1.5; OfficeLivePatch.1.3; MS-RTC LM 8; .NET4.0C; Media Center PC 6.0)

luca.passani
Posts: 65
Joined: Thu May 19, 2011 2:49 pm

Re: IE user-agent with "tablet" attribute detected as mobile

Postby luca.passani » Mon Jul 18, 2011 2:59 pm

I think you have a point there. We will fix it in the next API release

Luca

RecRedit
Posts: 1
Joined: Sun Oct 30, 2011 7:49 pm

Re: IE user-agent with "tablet" attribute detected as mobile

Postby RecRedit » Sun Oct 30, 2011 7:51 pm

Anyone know if this was changed with an update? Just curious thanks.
Last edited by RecRedit on Tue Nov 15, 2011 2:48 am, edited 1 time in total.

sm_support2
Posts: 294
Joined: Mon Jun 20, 2011 5:04 pm

Re: IE user-agent with "tablet" attribute detected as mobile

Postby sm_support2 » Wed Nov 02, 2011 12:55 pm

Release of the new minor version of the API which fixes this is running a bit late, but the change is still committed.

Thanks

Luca


Who is online

Users browsing this forum: No registered users and 4 guests