IOS 5 is detected as device_os_version 2

I have this HTTP request, I expected this, but WURFL is returning that. Please provide enough data to reproduce the problem.
julie
Posts: 1
Joined: Thu Oct 27, 2011 5:22 am

IOS 5 is detected as device_os_version 2

Postby julie » Thu Oct 27, 2011 5:30 am

Hello,

I get a wrong OS version with the follwing user-Agent on an iPhone 4 :
Mozilla/5.0 (iPhone; CPU iPhone OS 5_0 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A334 Safari/7534.48.3
-> device_os_version 2.0

While the iPad is read correctly :
Mozilla/5.0 (iPad; CPU OS 5_0 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A334 Safari/7534.48.3
-> device_os_version 5

Could you please fix this issue ?

Thank you

sm_support2
Posts: 294
Joined: Mon Jun 20, 2011 5:04 pm

Re: IOS 5 is detected as device_os_version 2

Postby sm_support2 » Thu Oct 27, 2011 8:17 am

it's already there. It will be available with the next public snapshot for paying customers and in the next public release for everyone else.

If you can't wait, just add this manually to your WURFL.xml

<device id="apple_ipod_touch_ver5" user_agent="Mozilla/5.0 (iPod; CPU iPhone OS 5_0 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A334 Safari/7534.48.3" fall_back="apple_ipod_touch_ver4" actual_device_root="true">
<group id="product_info">
<capability name="device_os_version" value="5.0"/>
<capability name="model_extra_info" value="5.0"/>
<capability name="release_date" value="2011_october"/>
</group>
</device>
<device id="apple_iphone_ver5" user_agent="Mozilla/5.0 (iPhone; CPU iPhone OS 5_0 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A334 Safari/7534.48.3" fall_back="apple_iphone_ver4" actual_device_root="true">
<group id="product_info">
<capability name="mobile_browser_version" value="5.1"/>
<capability name="device_os_version" value="5.0"/>
<capability name="model_extra_info" value="5.0"/>
<capability name="release_date" value="2011_october"/>
</group>
</device>

Thanks


Who is online

Users browsing this forum: Bing [Bot] and 1 guest