WURFL ID is coming up as 'cfnetwork_desktop_330'

I don't get it, <device> X has no capabilities in it!!!!
pawel.branski@foreseeresults.com
Posts: 4
Joined: Thu Oct 01, 2015 1:11 pm

WURFL ID is coming up as 'cfnetwork_desktop_330'

Postby pawel.branski@foreseeresults.com » Tue Feb 23, 2016 9:27 am

WURFL is not detecting the browser and OS correctly for Apple OS X with Safari. The WURFL ID is coming up as 'cfnetwork_desktop_330' and the browser is coming up as 'App 3.1'.

We use 51Degrees for another part of the application and that one seems to be detecting the Browser and Platform correctly.

Please advice on how this can be corrected.

Elliotfehr

Re: WURFL ID is coming up as 'cfnetwork_desktop_330'

Postby Elliotfehr » Tue Feb 23, 2016 9:36 am

Hello,

Are you able to provide the full User Agent string of the device that is resolving to 'cfnetwork_desktop_330'?

Thank you,

Elliot

pawel.branski@foreseeresults.com
Posts: 4
Joined: Thu Oct 01, 2015 1:11 pm

Re: WURFL ID is coming up as 'cfnetwork_desktop_330'

Postby pawel.branski@foreseeresults.com » Tue Feb 23, 2016 10:43 am

I don't know the user-agent ID as resolved by WURFL, which is why I posted a question on this forum.

However, the other part of the application that uses 51Degrees has the following user-agent info: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_5) AppleWebKit/534.57.7 (KHTML, like Gecko) Version/5.1.7 Safari/534.57.7

pawel.branski@foreseeresults.com
Posts: 4
Joined: Thu Oct 01, 2015 1:11 pm

Re: WURFL ID is coming up as 'cfnetwork_desktop_330'

Postby pawel.branski@foreseeresults.com » Tue Feb 23, 2016 10:51 am

So I have got these two user agents that are not resolving correctly. There may be more. I just picked the first two I could find.

- Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_5) AppleWebKit/534.57.7 (KHTML, like Gecko) Version/5.1.7 Safari/534.57.7
- Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_5) AppleWebKit/537.78.2 (KHTML, like Gecko) Version/6.1.6 Safari/537.78.2

Elliotfehr

Re: WURFL ID is coming up as 'cfnetwork_desktop_330'

Postby Elliotfehr » Tue Feb 23, 2016 10:54 am

The User Agent strings that you have provided are resolving to `safari_5_0_mac` and `safari_6_0_mac ` when running the latest version of the WURFL API (1.7.0) in high accuracy mode.

Are you able to let me know if you seeing a different result?

Thank you,

Elliot

pawel.branski@foreseeresults.com
Posts: 4
Joined: Thu Oct 01, 2015 1:11 pm

Re: WURFL ID is coming up as 'cfnetwork_desktop_330'

Postby pawel.branski@foreseeresults.com » Tue Feb 23, 2016 2:28 pm

So we are using API v1.6.1. Does that mean we need to upgrade?

Elliotfehr

Re: WURFL ID is coming up as 'cfnetwork_desktop_330'

Postby Elliotfehr » Wed Feb 24, 2016 9:52 am

I would recommend upgrading to the latest version (1.7.0), which will correctly identify the User Agent strings that you provided.

Please do not hesitate to let me know if you have any questions during the upgrade process.

Thank you,

Elliot

aaronp
Posts: 223
Joined: Wed Dec 09, 2015 12:39 pm

Re: WURFL ID is coming up as 'cfnetwork_desktop_330'

Postby aaronp » Fri Feb 26, 2016 4:47 pm

Hi Pawel,

I just wanted to follow up with you to see if you were able to successfully upgrade your API and return the expected values.

Look forward to hearing back and, as always, please feel free to let me know if you require any assistance.

Thank you,

Aaron


Who is online

Users browsing this forum: No registered users and 1 guest