14 devices that don't seem to be in your system.

Can you add this device?
abynthe_minded
Posts: 16
Joined: Fri Sep 02, 2016 11:16 am

14 devices that don't seem to be in your system.

Postby abynthe_minded » Fri Sep 02, 2016 11:22 am

I posted each of these UA strings into your form, and they all came back Generic Android.
  1. Alcatel ALA621BL Mozilla/5.0 (Linux; Android 5.1.1; A621BL Build/LMY47V) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/38.0.2125.102 Mobile Safari/537.36
  2. Alcatel ALA851L Mozilla/5.0 (Linux; Android 4.1.2; ALCATEL A851L Build/JZO54K) AppleWebKit/537.31 (KHTML, like Gecko) Chrome/26.0.1410.58 Mobile Safari/537.31
  3. Huawei HUH882L Mozilla/5.0 (Linux; U; Android 4.1.2; en-us; H882L Build/HuaweiH882L) AppleWebKit/534.30 (KHTML, like Gecko) Version/4.0 Mobile Safari/534.30
  4. LG LGL61AL Mozilla/5.0 (Linux; Android 5.1.1; LGL61AL Build/LMY47V) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/38.0.2125.102 Mobile Safari/537.36
  5. LG LGL81AL Mozilla/5.0 (Linux; Android 5.1.1; LGL81AL Build/LMY47V) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/38.0.2125.102 Mobile Safari/537.36
  6. LG LGL85C Mozilla/5.0 (Linux; U; Android 2.3.4; us-en; LGL85C Build/SlackerUA) AppleWebKit/533.1 (KHTML, like Gecko) Version/4.0 Safari/533.1
  7. Samsung SAS735C Mozilla/5.0 (Linux; U; Android 4.0.4; en-US; SCH-S735C Build/IMM76D) AppleWebKit/534.30 (KHTML, like Gecko) Version/4.0 Mobile Safari/534.30
  8. Samsung SAS738C Mozilla/5.0(Linux;U;Android 4.0.4;en-us:SCH-S738C BUILD/IMM76D)AppleWebKit/534.30(KHTML,like Gecko)Version/4.0 Mobile Safari/534.30
  9. Samsung SAS777C Mozilla/5.0 (Linux; Android 4.4.4; SM-S777C Build/KTU84P) AppleWebKit/537.36 (KHTML, like Gecko) SamsungBrowser/2.0 Chrome/34.0.1847.76 Mobile Safari/537.36
  10. Samsung SAS820L Mozilla/5.0 (Linux; U; Android 4.4.4; en-us; SM-S820L build/KTU84P) AppleWebkit/534.30 (KHTML, like Gecko) Version/4.0 mobile safari/534.30
  11. ZTE ZEZ791G Mozilla/5.0 (Linux; Android 4.4.4; en-us; ZTE-Z791G Build/KTU84P) AppleWebKit/537.16 (KHTML, like Gecko) Version/4.0 Chrome/30.0.0.0 Mobile Safari/537.16
  12. ZTE ZEZ818L Mozilla/5.0 (Linux; Android 5.0.2; ZTE-Z818L Build/LRX22G) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/37.0.0.0 Mobile Safari/537.36
  13. ZTE ZEZ828TL Mozilla/5.0 (Linux; Android 5.1.1; Z828TL Build/LMY47V) AppleWebKit/537.36 (KHTML, like Gecko)Chrome/46.0.2490.76 Mobile Safari/537.36
  14. ZTE ZEZ962BL Mozilla/5.0 (Linux; Android 5.1.1; ZTE-Z962BL Build/LMY47V; wv) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/46.0.2490.76 Mobile Safari/537.36

amark
Posts: 39
Joined: Mon May 30, 2016 4:59 am

Re: 14 devices that don't seem to be in your system.

Postby amark » Fri Sep 02, 2016 11:25 am

Hi Marc,

Thank you for the UA Strings. I will make sure these devices will be added into WURFL.

Thanks,

Amar
Mobile Data Analyst
ScientiaMobile

abynthe_minded
Posts: 16
Joined: Fri Sep 02, 2016 11:16 am

Re: 14 devices that don't seem to be in your system.

Postby abynthe_minded » Fri Sep 02, 2016 1:06 pm

I think I included a couple extra letters (from our own system code) by mistake. So ALA621BL should be A621BL. What the actual names of the phones (One Touch, Galaxy, etc are, I have no idea).

amark
Posts: 39
Joined: Mon May 30, 2016 4:59 am

Re: 14 devices that don't seem to be in your system.

Postby amark » Fri Sep 02, 2016 1:13 pm

Hi Marc,

No worries thank you for letting us know.

Regards,

Amar
Mobile Data Analyst
ScientiaMobile

abynthe_minded
Posts: 16
Joined: Fri Sep 02, 2016 11:16 am

Re: 14 devices that don't seem to be in your system.

Postby abynthe_minded » Thu Sep 08, 2016 3:05 pm

This phone seems to be reporting inaccurately.

Mozilla/5.0 (Linux; Android 5.1.1; Z717VL Build/LMY47V; wv) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/42.0.2311.137 Mobile Safari/537.36

It's coming up as a Z716VL, not Z717VL.

aaronp
Posts: 224
Joined: Wed Dec 09, 2015 12:39 pm

Re: 14 devices that don't seem to be in your system.

Postby aaronp » Thu Sep 08, 2016 3:49 pm

Hi Marc,

Thank you for letting us know. We have updated the model number in our database and the changes will be reflected in the next Snapshot release.

Feel free to let us know if you have any other questions or concerns.

Thanks,

Aaron

abynthe_minded
Posts: 16
Joined: Fri Sep 02, 2016 11:16 am

Re: 14 devices that don't seem to be in your system.

Postby abynthe_minded » Thu Sep 08, 2016 4:28 pm

You might get a couple more of these, I'm testing about 100.

Mozilla/5.0 (Linux; Android 4.4.4; en-us; Z936L Build/KTU84P) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/30.0.0.0 Mobile Safari/537.36

is coming up as Z296L

Should be Z936L

abynthe_minded
Posts: 16
Joined: Fri Sep 02, 2016 11:16 am

Re: 14 devices that don't seem to be in your system.

Postby abynthe_minded » Thu Sep 08, 2016 4:29 pm

Mozilla/5.0 (Linux; Android 5.1; ZTE-Z955L Build/LMY47D) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/39.0.0.0 Mobile Safari/537.36

is appearing as Z995L

Should be ZTE-Z955L

abynthe_minded
Posts: 16
Joined: Fri Sep 02, 2016 11:16 am

Re: 14 devices that don't seem to be in your system.

Postby abynthe_minded » Thu Sep 08, 2016 4:33 pm

Okay, that's it, but these six of my original list still didn't appear when I tested on Tuesday,

Mozilla/5.0 (Linux; Android 4.1.2; ALCATEL A851L Build/JZO54K) AppleWebKit/537.31 (KHTML, like Gecko) Chrome/26.0.1410.58 Mobile Safari/537.31

Mozilla/5.0 (Linux; Android 5.1.1; LGL81AL Build/LMY47V) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/38.0.2125.102 Mobile Safari/537.36

Mozilla/5.0 (Linux; U; Android 2.3.4; us-en; LGL85C Build/SlackerUA) AppleWebKit/533.1 (KHTML, like Gecko) Version/4.0 Safari/533.1

Mozilla/5.0(Linux;U;Android 4.0.4;en-us:SCH-S738C BUILD/IMM76D)AppleWebKit/534.30(KHTML,like Gecko)Version/4.0 Mobile Safari/534.30

Mozilla/5.0 (Linux; U; Android 4.4.4; en-us; SM-S820L build/KTU84P) AppleWebkit/534.30 (KHTML, like Gecko) Version/4.0 mobile safari/534.30

Mozilla/5.0 (Linux; Android 5.1.1; ZTE-Z962BL Build/LMY47V; wv) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/46.0.2490.76 Mobile Safari/537.36

abynthe_minded
Posts: 16
Joined: Fri Sep 02, 2016 11:16 am

Re: 14 devices that don't seem to be in your system.

Postby abynthe_minded » Mon Sep 12, 2016 10:29 am

poke

aaronp
Posts: 224
Joined: Wed Dec 09, 2015 12:39 pm

Re: 14 devices that don't seem to be in your system.

Postby aaronp » Mon Sep 12, 2016 10:51 am

Hi Marc,

The ZTE user agents have been updated in our database. In order to see the changes, you will need to update your `wurfl.xml` file. You can find the link for the update by logging into your organization's primary licensed account, then go to:

'My Account' -> 'View Account' for WURFL InFuze for NGINX (SMCommercial) -> https://data.scientiamobile.com/xxxxx/wurfl.zip (under WURFL Snapshot)

As for the other provided user agents, we did not add the following user agents as they are invalid:

Code: Select all

Mozilla/5.0 (Linux; U; Android 2.3.4; us-en; LGL85C Build/SlackerUA) AppleWebKit/533.1 (KHTML, like Gecko) Version/4.0 Safari/533.1    
Mozilla/5.0(Linux;U;Android 4.0.4;en-us:SCH-S738C BUILD/IMM76D)AppleWebKit/534.30(KHTML,like Gecko)Version/4.0 Mobile Safari/534.30    
Mozilla/5.0 (Linux; U; Android 4.4.4; en-us; SM-S820L build/KTU84P) AppleWebkit/534.30 (KHTML, like Gecko) Version/4.0 mobile safari/534.30
The following user agents have been added and the changes will be reflected in next week's WURFL Snapshot update:

Code: Select all

Mozilla/5.0 (Linux; Android 5.1.1; ZTE-Z962BL Build/LMY47V; wv) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/46.0.2490.76 Mobile Safari/537.36
Mozilla/5.0 (Linux; Android 4.1.2; ALCATEL A851L Build/JZO54K) AppleWebKit/537.31 (KHTML, like Gecko) Chrome/26.0.1410.58 Mobile Safari/537.31
Mozilla/5.0 (Linux; Android 5.1.1; LGL81AL Build/LMY47V) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/38.0.2125.102 Mobile Safari/537.36
Feel free to give us a heads up if you have any further questions or concerns.

Thanks,

Aaron

abynthe_minded
Posts: 16
Joined: Fri Sep 02, 2016 11:16 am

Re: 14 devices that don't seem to be in your system.

Postby abynthe_minded » Tue Sep 13, 2016 3:06 pm

Thank you. I'll contact the cellular provider to see if I can get correct UAs, for those three invalid ones.

This one though,
Mozilla/5.0(Linux;U;Android 4.0.4;en-us:SCH-S738C BUILD/IMM76D)AppleWebKit/534.30(KHTML,like Gecko)Version/4.0 Mobile Safari/534.30

I noticed there's a colon where a semi-colon should be. See if this works.

Code: Select all

Mozilla/5.0 (Linux; U; Android 4.0.4; en-us; SCH-S738C BUILD/IMM76D) AppleWebKit/534.30 (KHTML, like Gecko) Version/4.0 Mobile Safari/534.30  

aaronp
Posts: 224
Joined: Wed Dec 09, 2015 12:39 pm

Re: 14 devices that don't seem to be in your system.

Postby aaronp » Wed Sep 14, 2016 1:43 pm

Hi Marc,

The user agent is still invalid as "BUILD" should not be capitalized.

Aaron

abynthe_minded
Posts: 16
Joined: Fri Sep 02, 2016 11:16 am

Re: 14 devices that don't seem to be in your system.

Postby abynthe_minded » Thu Sep 15, 2016 1:50 pm

Ah, cool, this works then. I'm down to two non-working UAs.

Code: Select all

Mozilla/5.0 (Linux; U; Android 4.0.4; en-us; SCH-S738C Build/IMM76D) AppleWebKit/534.30 (KHTML, like Gecko) Version/4.0 Mobile Safari/534.30

aaronp
Posts: 224
Joined: Wed Dec 09, 2015 12:39 pm

Re: 14 devices that don't seem to be in your system.

Postby aaronp » Thu Sep 15, 2016 2:01 pm

Hi Marc,

Thanks for the update! This user agent has been in our database and, if you are unable to properly detect it, you may want to try updating your WURFL Snapshot.

Aaron

abynthe_minded
Posts: 16
Joined: Fri Sep 02, 2016 11:16 am

Re: 14 devices that don't seem to be in your system.

Postby abynthe_minded » Fri Sep 16, 2016 12:25 pm

I suspect the problem is with the UAs we were given, not that we don't have an up to date snapshot (which we don't, but will be updating shortly). I'm testing them in the app you have on your website.

Right now we're going to see if we can pull the UAs from our server logs, and then try them in your app. Hopefully that's all that needs to be done.

abynthe_minded
Posts: 16
Joined: Fri Sep 02, 2016 11:16 am

Re: 14 devices that don't seem to be in your system.

Postby abynthe_minded » Fri Sep 16, 2016 12:28 pm

This is still happening in your ua checking app.
abynthe_minded wrote:Mozilla/5.0 (Linux; Android 5.1; ZTE-Z955L Build/LMY47D) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/39.0.0.0 Mobile Safari/537.36

is appearing as Z995L

Should be ZTE-Z955L

aaronp
Posts: 224
Joined: Wed Dec 09, 2015 12:39 pm

Re: 14 devices that don't seem to be in your system.

Postby aaronp » Fri Sep 16, 2016 1:39 pm

Hi Marc!

If the `model_name` capability is what you are referring to, the return value is intended to be `Z955L`. The model name will not include the brand as well. However, if you are looking for both the brand and model name (ex. Samsung Galaxy S5), you will want to use the `complete_device_name` virtual capability which will concatenate the device's brand and model name.

Let me know if there is anything else I can clarify for you.

Thanks,

Aaron

abynthe_minded
Posts: 16
Joined: Fri Sep 02, 2016 11:16 am

Re: 14 devices that don't seem to be in your system.

Postby abynthe_minded » Fri Sep 16, 2016 3:43 pm

No, I believe they are two different (slightly) devices, the Z955L and the Z995L, although both are ZMax 2s.

aaronp
Posts: 224
Joined: Wed Dec 09, 2015 12:39 pm

Re: 14 devices that don't seem to be in your system.

Postby aaronp » Fri Sep 16, 2016 3:50 pm

Hi Marc,

I see what you are saying and will notify my mobile data team to get the user agent's model updated.

Thanks,

Aaron


Who is online

Users browsing this forum: No registered users and 1 guest