Can not even run demo yet

rjsig
Posts: 1
Joined: Fri Apr 06, 2012 9:02 pm

Can not even run demo yet

Postby rjsig » Fri Apr 06, 2012 9:07 pm

I downloaded the php version today and unzipped to my shared hostgator server. I can not even run the example demo index.php without getting the following error:

Fatal error: Declaration of WURFL_Storage_Base::save() must be compatible with that of WURFL_Storage::save() in /home/xxxx/public_html/resources/wurfl-php-1.4.0/WURFL/Storage/Base.php on line 31

You can see at: http://resources.rjsig.com/wurfl-php-1. ... ples/demo/

Please advise.

kamermans
Posts: 392
Joined: Mon Jun 06, 2011 9:50 am

Re: Can not even run demo yet

Postby kamermans » Sat Apr 07, 2012 9:26 am

We have been able to reproduce the problem on PHP 5.1, and have released an updated version (1.4.1) that should work fine. Please let me know if the problem remains.
Thanks,

Steve Kamerman
ScientiaMobile

Make sure you check out our WURFL Cloud, WURFL InSight and WURFL InFuze products!

gopal
Posts: 1
Joined: Sat May 13, 2017 3:34 am

Re: Can not even run demo yet

Postby gopal » Sat May 13, 2017 3:36 am

trouble in installation and running demo
need help

Fatal error: Class 'ScientiaMobile\WURFL\Container\Container' not found in /home/clocktfc/public_html/testwurfl/vendor/scientiamobile/wurfl-api/config/config.php.example on line 20

aaronp
Posts: 191
Joined: Wed Dec 09, 2015 12:39 pm

Re: Can not even run demo yet

Postby aaronp » Mon May 15, 2017 10:07 am

Hi,

Thank you for reaching out to us. Are you able to provide me with the following information:

- PHP API Version
- PHP API Config file
- patch files (if any)
- Code sample
- The storage or cache type and version (if not File, example: Redis 3.2.8, MySQL 5.7.18)
- OS Name and Version

Thanks,

Aaron


Who is online

Users browsing this forum: No registered users and 1 guest