The WURFL repository has not been loaded. Please run the "..

sam@WU2013
Posts: 11
Joined: Tue Feb 21, 2017 4:09 am

The WURFL repository has not been loaded. Please run the "..

Postby sam@WU2013 » Wed Feb 22, 2017 3:16 am

I try to upgrade our system to PHP 7, and make use of API from onsite_1.8.3.0_PHP_API_14258.zip

I had created the following test code.

Code: Select all

                $container = new \ScientiaMobile\WURFL\Container\Container([
                    'wurfl_snapshot_url' => __DIR__ . '/../wurfl/wurfl.zip',
                    'wurfl_storage_path' => __DIR__ . '/../wurfl/storage',
                    'wurfl_capability_filter' => [
                        'advertised_browser',
                        'advertised_browser_version',
                        'advertised_device_os',
                        'advertised_device_os_version',
                        'cookie_support',
                        'form_factor',
                        'device_os',
                        'device_os_version',
                        'is_tablet',
                        'is_wireless_device',
                        'pointing_method',
                        'preferred_markup',
                        'resolution_height',
                        'resolution_width',
                        'ux_full_desktop',
                        'xhtml_support_level',
                        'is_smarttv',
                        'can_assign_phone_number',
                        'brand_name',
                        'model_name',
                        'marketing_name',
                        'mobile_browser_version'
                    ]
                ]);

                $wurfl_engine = new \ScientiaMobile\WURFL\WURFLEngine($container);
However, exception being thrown when I construct WURFLEngine.

I had print out the value of

__DIR__ . '/../wurfl/wurfl.zip'

and

__DIR__ . '/../wurfl/storage'

They are pointing to a valid zip file and valid directory.

I was wondering, why I am still getting

Code: Select all

The WURFL repository has not been loaded. Please run the "wurfl-updater" script.

sam@WU2013
Posts: 11
Joined: Tue Feb 21, 2017 4:09 am

Re: The WURFL repository has not been loaded. Please run the

Postby sam@WU2013 » Wed Feb 22, 2017 3:50 am

I even try to add wurfl_db, it doesn't help. Same exception still happens

Code: Select all

                $container = new \ScientiaMobile\WURFL\Container\Container([
                    'wurfl_db' => __DIR__ . '/../wurfl/wurfl.zip',
                    'wurfl_snapshot_url' => __DIR__ . '/../wurfl/wurfl.zip',
                    'wurfl_storage_path' => __DIR__ . '/../wurfl/storage',
                    'wurfl_capability_filter' => [
                        'advertised_browser',
                        'advertised_browser_version',
                        'advertised_device_os',
                        'advertised_device_os_version',
                        'cookie_support',
                        'form_factor',
                        'device_os',
                        'device_os_version',
                        'is_tablet',
                        'is_wireless_device',
                        'pointing_method',
                        'preferred_markup',
                        'resolution_height',
                        'resolution_width',
                        'ux_full_desktop',
                        'xhtml_support_level',
                        'is_smarttv',
                        'can_assign_phone_number',
                        'brand_name',
                        'model_name',
                        'marketing_name',
                        'mobile_browser_version'
                    ]
                ]);

                $wurfl_engine = new \ScientiaMobile\WURFL\WURFLEngine($container);

aaronp
Posts: 229
Joined: Wed Dec 09, 2015 12:39 pm

Re: The WURFL repository has not been loaded. Please run the

Postby aaronp » Wed Feb 22, 2017 8:55 am

Hi Hwa,

Thank you for letting us know. We will check out the provided user agent string and follow up with you once we have an update.

Also, I would highly recommend that you update your API to v1.8.3 as we have made many detection and performance enhancements since v1.7.1

Thanks,

Aaron

aaronp
Posts: 229
Joined: Wed Dec 09, 2015 12:39 pm

Re: The WURFL repository has not been loaded. Please run the

Postby aaronp » Wed Feb 22, 2017 1:49 pm

Hi Hwa,

While we are looking at the provided user agent string, are you able to run the WURFL updater

Code: Select all

php -d memory_limit=1024M /path/to/wurfl-updater -c /path/to/config.php
The following documentation details the WURFL Updater: https://docs.scientiamobile.com/documen ... te-php-api

Aaron


Who is online

Users browsing this forum: No registered users and 1 guest