Is PHP API v1.8.x.x requires PHP 5.3 or PHP 5.4

sam@WU2013
Posts: 11
Joined: Tue Feb 21, 2017 4:09 am

Is PHP API v1.8.x.x requires PHP 5.3 or PHP 5.4

Postby sam@WU2013 » Tue Apr 11, 2017 5:14 am

I'm trying to use WURFL in a legacy project which is running on PHP 5.3

I look at https://docs.scientiamobile.com/documen ... tabase-api , the PHP requirements is

Code: Select all

PHP 5.3+
However, I use the following composer.json

Code: Select all


    "repositories": [
        {
            "type": "artifact",
            "url": "wurfl/"
        },
    ...
    "require": {
        "scientiamobile/wurfl-api": "*",

When I run composer update, I get the following error
Problem 1
- Installation request for scientiamobile/wurfl-api * -> satisfiable by scientiamobile/wurfl-api[1.8.3.0].
- scientiamobile/wurfl-api 1.8.3.0 requires php >=5.4 -> your PHP version (5.6.23-1+deprecated+dontuse+deb.sury.org~trusty+1) or "config.platform.php" value does not satisfy that requirement.
I'm confusing right now. Can we still use WURFL in PHP 5.3 ?

aaronp
Posts: 228
Joined: Wed Dec 09, 2015 12:39 pm

Re: Is PHP API v1.8.x.x requires PHP 5.3 or PHP 5.4

Postby aaronp » Tue Apr 11, 2017 11:14 am

Hi,

Thanks for reaching out. I noticed that the documentation that you provided is for the PHP-DB API - separate from the PHP API. The minimum PHP requirement for the PHP API is PHP >= 5.4 (suggested 5.6 or higher) while the minimum for the PHP-DB API is PHP >= 5.3

The documentation you will want to follow: https://docs.scientiamobile.com/documen ... te-php-api

Also, do note that, while there is no concrete ETA, the PHP-DHB API will be discontinued in the near future. We've taken the best parts of the DB-API and integrated them into the standard PHP API. The PHP API is now faster than the DB-API and the storage backend of the PHP API is configurable (so you can use an improved file-based backend, MySQL, MongoDB, memcached and more).

Hope this clarifies things for you. Let me know if you have any further questions or concerns.

Thanks,

Aaron

sam@WU2013
Posts: 11
Joined: Tue Feb 21, 2017 4:09 am

Re: Is PHP API v1.8.x.x requires PHP 5.3 or PHP 5.4

Postby sam@WU2013 » Tue Apr 11, 2017 8:56 pm

Hem...

Sorry. I am getting confused.

May I know what is the difference between "onsite php api" and "onsite php database api" ? Which api we should be using based on the our use case?

Our use case is

User makes a request to our web application written in PHP. Our web application will perform analysis on user agent string, and decide what kind of output render to user. The entire operation needs to be fast and less than seconds.

aaronp
Posts: 228
Joined: Wed Dec 09, 2015 12:39 pm

Re: Is PHP API v1.8.x.x requires PHP 5.3 or PHP 5.4

Postby aaronp » Wed Apr 12, 2017 10:55 am

Hi Sam,

With recent developments, the differences between the OnSite PHP and OnSite PHP-DB API have been narrowed heavily since the release of v1.8

As mentioned in my previous response, our engineering team has taken the best of the PHP-DB API and integrated them into the PHP API. With that said, the DB API will be deprecated sometime in the near future.

Based on your use case, you will definitely want to use the PHP API (it is also what you are currently licensed for) as it is now faster and can handle the same tasks more efficiently than the PHP-DB API.

Feel free to give it a try and let me know if you have any questions along the way!

Thanks,

Aaron

kamermans
Posts: 393
Joined: Mon Jun 06, 2011 9:50 am

Re: Is PHP API v1.8.x.x requires PHP 5.3 or PHP 5.4

Postby kamermans » Wed Apr 12, 2017 11:32 am

Hi, let me expand on Aaron's answer.

> May I know what is the difference between "onsite php api" and "onsite php database api" ? Which api we should be using based on the our use case?

The WURFL OnSite API is available in two forms for PHP, the standard PHP API, and the so-called "PHP Database API". Both APIs do the same thing, and can be used interchangeably. The reason we have two APIs for PHP is that when ScientiaMobile was formed, it inherited the standard PHP API from the WURFL project, and an API called Tera-WURFL from co-founder Steve Kamerman (me). Tera-WURFL had a very large following, so we developed both APIs in parallel for a few years. Now we have combined the best features of both APIs into the standard PHP API and we are deprecating the PHP Database API (Tera-WURFL). It is highly recommended that you use the standard PHP API, although, as Aaron mentioned, it requires PHP 5.4+. We made the jump to requiring PHP 5.4+ last year due to significant enhancements in the language, and the fact that PHP 5.3 was deprecated and all support was dropped by the PHP team in 2014 (PHP 5.4 and 5.5 are also end-of-life, btw).
Thanks,

Steve Kamerman
ScientiaMobile

Make sure you check out our WURFL Cloud, WURFL InSight and WURFL InFuze products!


Who is online

Users browsing this forum: No registered users and 1 guest